summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexander Larsson <alla@lysator.liu.se>2001-01-09 09:53:28 +0000
committerAlexander Larsson <alexl@src.gnome.org>2001-01-09 09:53:28 +0000
commit7e3eadd61ca2304b2f9fa0430c2f1271c41b49ab (patch)
treef46d3321517dde86548b773b14595da1a941f23e /configure.in
parent136232bcd6e64a3b7012d215c2e2f9d1a7a98c09 (diff)
downloadgtk+-7e3eadd61ca2304b2f9fa0430c2f1271c41b49ab.tar.gz
Added --with-included-loaders option
2001-01-09 Alexander Larsson <alla@lysator.liu.se> * configure.in: Added --with-included-loaders option * gdk-pixbuf/Makefile.am: * gdk-pixbuf/gdk-pixbuf-io.c: Add support for including selected gdk-pixbuf loaders only. * gtk/gtkwindow.c (gtk_window_set_frame_dimensions, gtk_window_set_has_frame): Added inline documentation. * gdk/x11/gdkwindow-x11.c (gdk_window_get_decorations): * docs/reference/gdk/tmpl/windows.sgml: Added inline documentation.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 34 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1ba38f09f5..e1beebac44 100644
--- a/configure.in
+++ b/configure.in
@@ -896,6 +896,40 @@ AC_SUBST(LIBPNG)
AM_CONDITIONAL(BUILD_DYNAMIC_MODULES, $dynworks)
+#
+# Allow building some or all gdk-pixbuf loaders included
+#
+AC_MSG_CHECKING(pixbuf loaders to build)
+
+AC_ARG_WITH(included_loaders, [ --with-included-loaders=LOADER1,LOADER2,... Build the specified loaders into gdk-pixbuf (only used if module loading disabled)])
+
+all_loaders="png,bmp,wbmp,gif,ico,jpeg,pnm,ras,tiff,xpm"
+included_loaders=""
+# If no loaders specified, include all
+if test "x$with_included_loaders" = x ; then
+ included_loaders="$all_loaders"
+else
+ included_loaders="$with_included_loaders"
+fi
+
+AC_MSG_RESULT($included_loaders)
+
+INCLUDED_LOADER_OBJ=
+INCLUDED_LOADER_DEFINE=
+
+IFS="${IFS= }"; gtk_save_ifs="$IFS"; IFS=","
+for loader in $included_loaders; do
+ if ! echo "$all_loaders" | grep "\(^\|\,\)$loader\(\$\|\,\)" > /dev/null; then
+ AC_MSG_ERROR([the specified loader $loader does not exist])
+ fi
+
+ INCLUDED_LOADER_OBJ="$INCLUDED_LOADER_OBJ libpixbufloader-static-$loader.la"
+ INCLUDED_LOADER_DEFINE="$INCLUDED_LOADER_DEFINE -DINCLUDE_$loader"
+done
+IFS="$gtk_save_ifs"
+AC_SUBST(INCLUDED_LOADER_OBJ)
+AC_SUBST(INCLUDED_LOADER_DEFINE)
+
AC_HEADER_STDC
AC_HEADER_DIRENT
AC_HEADER_SYS_WAIT