summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-09-07 18:17:06 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-09-07 18:17:06 +0000
commit71337db92ebab296f2567d88f06d472d2f7584d5 (patch)
tree08518ab5fd33fdb8eea95b200b34c05246d35c55 /configure.in
parent21b538970edd944b694f44e8a7c9f7256dca02d3 (diff)
downloadgtk+-71337db92ebab296f2567d88f06d472d2f7584d5.tar.gz
Move gtk-reference files into GTK+ tree proper.
Thu Sep 7 14:15:03 2000 Owen Taylor <otaylor@redhat.com> * gdk/* gtk/*: Move gtk-reference files into GTK+ tree proper. * Update sections.txt files to correspond to current code, tweak .sgml files and Makefiles to correspond. * gtk/tmpl/gtkradiomenuitem.sgml (this): Remove extra <para>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4b05b6f0f9..d33a4fe309 100644
--- a/configure.in
+++ b/configure.in
@@ -870,6 +870,16 @@ AM_CONDITIONAL(USE_MMX, test x$use_mmx_asm = xyes)
# Checks for gtk-doc and docbook-tools
##################################################
+AC_ARG_WITH(html-dir, [ --with-html-dir=PATH path to installed docs ])
+
+if test "x$with_html_dir" = "x" ; then
+ HTML_DIR='${datadir}/gtk-doc/html'
+else
+ HTML_DIR=$with_html_dir
+fi
+
+AC_SUBST(HTML_DIR)
+
AC_CHECK_PROG(GTKDOC, gtkdoc-mkdb, true, false)
AM_CONDITIONAL(HAVE_GTK_DOC, $GTKDOC)
AC_SUBST(HAVE_GTK_DOC)
@@ -1002,6 +1012,8 @@ demos/Makefile
docs/Makefile
docs/reference/Makefile
docs/reference/gdk-pixbuf/Makefile
+docs/reference/gdk/Makefile
+docs/reference/gtk/Makefile
docs/faq/Makefile
docs/tutorial/Makefile
gdk-pixbuf/Makefile