summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2007-01-04 15:05:07 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2007-01-04 15:05:07 +0000
commit3b54167d991f134fa8f464e34547c27bcd5d4228 (patch)
tree806c57fc9e12fec93d30ff00e37f5dafca90b8a5 /configure.in
parent0bf8e61f8ad15b4d1f376596dc1b62159b2afa06 (diff)
downloadgtk+-3b54167d991f134fa8f464e34547c27bcd5d4228.tar.gz
Cross-compilation fixes. (#392646, Yevgen Muntyan)
2007-01-04 Matthias Clasen <mclasen@redhat.com> * gtk/Makefile.am: * gdk-pixbuf/Makefile.am: * configure.in: * gdk/win32/rc/gdk.rc.in: Cross-compilation fixes. (#392646, Yevgen Muntyan) svn path=/trunk/; revision=17065
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2d798d1998..06bbaf1ddf 100644
--- a/configure.in
+++ b/configure.in
@@ -1009,7 +1009,8 @@ AM_CONDITIONAL(CROSS_COMPILING, test $cross_compiling = yes)
if test $cross_compiling = yes; then
AC_PATH_PROG(GDK_PIXBUF_CSOURCE, gdk-pixbuf-csource, no)
- if test x$GDK_PIXBUF_CSOURCE = xno; then
+ AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache, no)
+ if test x$GTK_UPDATE_ICON_CACHE = xno; then
REBUILD_PNGS=#
fi
fi
@@ -1019,7 +1020,7 @@ if test ! -f $srcdir/gtk/gtkbuiltincache.h &&
AC_MSG_ERROR([
*** gtkbuiltincache.h is not in the tree, and cannot be built
*** because you don't have libpng, or (when cross-compiling) you
-*** don't have a prebuilt gdk-pixbuf-csource on the host system.])
+*** don't have a prebuilt gtk-update-icon-cache on the build system.])
fi
AC_SUBST(REBUILD_PNGS)