summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>1998-12-02 03:40:03 +0000
committerTim Janik <timj@src.gnome.org>1998-12-02 03:40:03 +0000
commit0d15bc6687e9a9718273a37b3d880f6526fa91ce (patch)
treea81db6a4b796eccad75dc6b9f0ba04cb664ddebc /configure.in
parent4ebc61c067af80a3cd24f1cfd79ec6b6be80e350 (diff)
downloadgtk+-0d15bc6687e9a9718273a37b3d880f6526fa91ce.tar.gz
s/gtk_notebook_nth_page/gtk_notebook_get_nth_page/.
Wed Dec 2 01:39:02 1998 Tim Janik <timj@gtk.org> * gtk/gtknotebook.h: * gtk/gtknotebook.c: s/gtk_notebook_nth_page/gtk_notebook_get_nth_page/. * incremented version number to 1.1.6 and made Gtk dependant on GLib 1.1.6. * gtk/gtkwidget.h (struct _GtkRequisition): changed width and height from guint16 to gint16, since sizes bigger than 32767 are not supported anyways, and aritmethics with intermediate negative values are possible now. Tue Dec 1 00:00:04 1998 Tim Janik <timj@gtk.org> * gtk/gtkscrolledwindow.c: implementation of GTK_POLICY_NEVER functionality, added rationales on the policy and size requisition handling at the top. (gtk_scrolled_window_size_request): we assume a default minimum for our child's width and height if [hv]scrollbar_policy != GTK_POLICY_NEVER, except when the user specified the dimension explicitely. (gtk_scrolled_window_size_allocate): do not show scrollbars if [hv]scrollbar_policy == GTK_POLICY_NEVER. * gtk/gtkviewport.c (gtk_viewport_size_request): report the real size we require (including the child). * gtk/gtkclist.c: (gtk_clist_size_request): report the real size required. * gtk/gtkenums.h (enum GtkPolicyType): added GTK_POLICY_NEVER. * gtk/gtkobject.c (gtk_object_init_type): object_type doesn't need to be a static variable. Mon Nov 30 22:41:25 1998 Tim Janik <timj@gtk.org> * gtk/gtkclist.h: * gtk/gtkclist.c: * gtk/gtkviewport.h: * gtk/gtkviewport.c: * gtk/gtktext.h: * gtk/gtktext.c: * gtk/gtklayout.h: * gtk/gtklayout.c: * gtk/gtkwidget.h: * gtk/gtkwidget.c: * gtk/gtkscrolledwindow.h: * gtk/gtkscrolledwindow.c: s/scroll_adjustements/scroll_adjustments/ s/scroll_adjustments/set_scroll_adjustments/g
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3d01e851d3..a2870a575f 100644
--- a/configure.in
+++ b/configure.in
@@ -14,7 +14,7 @@ cflags_set=${CFLAGS+set}
#
GTK_MAJOR_VERSION=1
GTK_MINOR_VERSION=1
-GTK_MICRO_VERSION=5
+GTK_MICRO_VERSION=6
GTK_INTERFACE_AGE=0
GTK_BINARY_AGE=0
GTK_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$GTK_MICRO_VERSION
@@ -175,7 +175,7 @@ fi
if test x$with_glib = x ; then
# Look for separately installed glib
- AM_PATH_GLIB(1.1.5,,
+ AM_PATH_GLIB(1.1.6,,
AC_MSG_ERROR([
*** GLIB 1.1.5 or better is required. The latest version of GLIB
*** is always available from ftp://ftp.gtk.org.]),