summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2005-07-08 03:57:39 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2005-07-08 03:57:39 +0000
commitd2742356a442132cfd07955c1a96c91da143aa7c (patch)
tree6a931c83cc03498848c3fee89ee3a3ed303db2ac /configure.in
parentb37d8bf8a67f1663aaa397da5f0cd225b61579a1 (diff)
downloadgtk+-d2742356a442132cfd07955c1a96c91da143aa7c.tar.gz
Add -DHPPEX -DSHMLINK to CFLAGS for HP-UX. (#162979, Paul Cornett)
2005-07-07 Matthias Clasen <mclasen@redhat.com> * configure.in: Add -DHPPEX -DSHMLINK to CFLAGS for HP-UX. (#162979, Paul Cornett)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3e7fd38472..e1e8d3dabc 100644
--- a/configure.in
+++ b/configure.in
@@ -471,6 +471,20 @@ case $host in
;;
esac
+#
+# see bug 162979
+#
+AC_MSG_CHECKING(for HP-UX)
+case $host_os in
+ hpux9* | hpux10* | hpux11*)
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -DHPPEX -DSHMLINK"
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+esac
+
dnl NeXTStep cc seems to need this
AC_MSG_CHECKING([for extra flags for POSIX compliance])
AC_TRY_COMPILE([#include <dirent.h>], [DIR *dir;],