summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-10-29 17:25:40 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-10-29 17:25:40 +0000
commitededbc646c89796edb0f84a89dd4efd4714262d6 (patch)
treea1720b68420d0edc4a8631a698c5a79cfae8f06c /configure.in
parent1493f6f7d4f4b49cc95fc1693cbee19fd3573503 (diff)
downloadgtk+-ededbc646c89796edb0f84a89dd4efd4714262d6.tar.gz
Don't use AC_CHECK_FILE to check for a file since it always spits warnings
Mon Oct 29 12:21:49 2001 Owen Taylor <otaylor@redhat.com> * configure.in: Don't use AC_CHECK_FILE to check for a file since it always spits warnings about cross compilation, use -f instead. It's not like we cross compile properly anyways. * configure.in (gtktargetlib): Move call to AC_PROG_CC to suppress autoconf warning. * acconfig.h: Add some missing #undefs from recent Win32 additions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 051877e2a1..48dacc8019 100644
--- a/configure.in
+++ b/configure.in
@@ -102,6 +102,7 @@ AM_INIT_AUTOMAKE($PACKAGE, $VERSION, no-define)
AM_CONFIG_HEADER(config.h)
dnl Initialize libtool
+AC_PROG_CC
AC_LIBTOOL_WIN32_DLL
AM_PROG_LIBTOOL
@@ -216,7 +217,6 @@ AC_DEFINE_UNQUOTED(GTK_COMPILED_WITH_DEBUGGING, "${enable_debug}")
AM_SANITY_CHECK
# Checks for programs.
-AC_PROG_CC
AC_ISC_POSIX
AM_PROG_CC_STDC
AC_PROG_INSTALL
@@ -391,12 +391,14 @@ if test ${with_wintab+set} = set && test $with_wintab != no; then
#include <wintab.h>],
[],
[AC_MSG_RESULT(yes)
- AC_CHECK_FILE([$with_wintab/lib/i386/wntab32x.lib],
- [have_wintab=yes
- AC_DEFINE(HAVE_WINTAB)
- WINTAB_LIB="$with_wintab/lib/i386/wntab32x.lib"
- AC_SUBST(WINTAB_LIB)],
- [have_wintab=no])
+ if test -f $with_wintab/lib/i386/wntab32x.lib ; then
+ have_wintab=yes
+ AC_DEFINE(HAVE_WINTAB)
+ WINTAB_LIB="$with_wintab/lib/i386/wntab32x.lib"
+ AC_SUBST(WINTAB_LIB)
+ else
+ have_wintab=no
+ fi
],
[AC_MSG_RESULT(no)
have_wintab=no])