summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@src.gnome.org>2002-07-26 22:21:39 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-07-26 22:21:39 +0000
commitba0a457c84378742bdc9abd0f0633d3ed7585441 (patch)
tree60e9c1c04ca90a9c0d200a5bd5f2826026007286 /configure.in
parent6c3caf2a9c6bbc07289941355fabfc61bc805601 (diff)
downloadgtk+-ba0a457c84378742bdc9abd0f0633d3ed7585441.tar.gz
ri Jul 26 17:59:06 2002 Owen Taylor <otaylor@redhat.com>
* configure.in: Replace uses of grep \(A\|B\) ... with egrep (A|B). (#84872, Arnaud Charlet)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index eb9c034021..29d9fa1d51 100644
--- a/configure.in
+++ b/configure.in
@@ -789,7 +789,7 @@ INCLUDED_LOADER_DEFINE=
IFS="${IFS= }"; gtk_save_ifs="$IFS"; IFS=","
for loader in $included_loaders; do
- if echo "$all_loaders" | grep "\(^\|\,\)$loader\(\$\|\,\)" > /dev/null; then
+ if echo "$all_loaders" | egrep "(^|,)$loader(\$|,)" > /dev/null; then
:
else
AC_MSG_ERROR([the specified loader $loader does not exist])
@@ -812,13 +812,13 @@ AM_CONDITIONAL(HAVE_JPEG, test "x$LIBJPEG" != x)
if $dynworks ; then
STATIC_LIB_DEPS=
- if echo "$included_loaders" | grep "\(^\|\,\)tiff\(\$\|\,\)" > /dev/null; then
+ if echo "$included_loaders" | egrep '(^|,)tiff($|,)' > /dev/null; then
STATIC_LIB_DEPS="$STATIC_LIB_DEPS $LIBTIFF"
fi
- if echo "$included_loaders" | grep "\(^\|\,\)jpeg\(\$\|\,\)" > /dev/null; then
+ if echo "$included_loaders" | egrep '(^|,)jpeg($|,)' > /dev/null; then
STATIC_LIB_DEPS="$STATIC_LIB_DEPS $LIBJPEG"
fi
- if echo "$included_loaders" | grep "\(^\|\,\)png\(\$\|\,\)" > /dev/null; then
+ if echo "$included_loaders" | egrep '(^|,)png($|,)' > /dev/null; then
STATIC_LIB_DEPS="$STATIC_LIB_DEPS $LIBPNG"
fi
else