summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2015-07-25 23:22:04 -0400
committerMatthias Clasen <mclasen@redhat.com>2015-07-25 23:22:04 -0400
commit62d785a6b71ba46615b4808db5b25d7404134563 (patch)
tree83abc971508e9d4d88ce3cc853403f53a7019ad9 /configure.ac
parent69d90d4f50b7611f6d59ac1409adb798f73e7797 (diff)
downloadgtk+-62d785a6b71ba46615b4808db5b25d7404134563.tar.gz
Don't use libcanberra without X
libcanberra calls x11 backend functions, so we can't use it when the x11 backend is disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6d9da29c07..28073626b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1690,6 +1690,10 @@ AC_ARG_ENABLE(libcanberra,
[enable_libcanberra="$enableval"],
[enable_libcanberra=auto])
+if test "$enable_x11_backend" != "yes"; then
+ enable_libcanberra=no
+fi
+
AC_MSG_CHECKING([whether to use libcanberra])
if test "$enable_libcanberra" != "no"; then
AC_MSG_RESULT([yes])