summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Bradford <rob@linux.intel.com>2013-01-17 16:05:25 +0000
committerRob Bradford <rob@linux.intel.com>2013-01-18 08:56:47 +0000
commit46cc2d825e1f86bdf120eb8149a549c6b639da2e (patch)
tree7159bb737168eb7a5331346d660c3915660a4654 /configure.ac
parentbb10561450eccca37df02ff5fbb5e01b7902aeae (diff)
downloadgtk+-46cc2d825e1f86bdf120eb8149a549c6b639da2e.tar.gz
wayland: Drop build configuration support for cairo-gl
The underlying code uses API that is no longer available with 1.0. This optional, off by default build mode hasn't worked since the release of Wayland 1.0.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 2 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index c16fec6628..6908f896a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -322,12 +322,6 @@ AC_ARG_ENABLE(quartz-relocation,
[enable bundle-based relocation functions])],
[quartz_relocation=yes])
-AC_ARG_ENABLE(wayland-cairo-gl,
- AS_HELP_STRING([--enable-wayland-cairo-gl],
- [enable the use of Cairo GL in the Wayland backend]),
- [enable_wayland_cairo_gl=yes])
-
-
cairo_backends=
backend_immodules=
have_gio_unix=no
@@ -397,22 +391,13 @@ else
fi
if test "x$enable_wayland_backend" = "xyes"; then
- if test "x$enable_wayland_cairo_gl" = "xyes"; then
- # Wayland can use cairo-gl
- cairo_backends="$cairo_backends cairo-gl"
- AC_DEFINE(GDK_WAYLAND_USE_EGL, [1], [Whether to use EGL in Wayland backend])
- else
- # For the cairo image backend
- cairo_backends="$cairo_backends cairo"
- fi
+ # For the cairo image backend
+ cairo_backends="$cairo_backends cairo"
GDK_BACKENDS="$GDK_BACKENDS wayland"
have_gio_unix=yes
GDK_WINDOWING="$GDK_WINDOWING
#define GDK_WINDOWING_WAYLAND"
WAYLAND_PACKAGES="wayland-client >= 1.0.0 xkbcommon >= 0.2.0 wayland-cursor"
- if test "x$enable_wayland_cairo_gl" = "xyes"; then
- WAYLAND_PACKAGES="$WAYLAND_PACKAGES wayland-egl egl"
- fi
AM_CONDITIONAL(USE_WAYLAND, true)
else
AM_CONDITIONAL(USE_WAYLAND, false)