summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimoc@gnome.org>2010-11-19 18:00:55 +0100
committerCosimo Cecchi <cosimoc@gnome.org>2010-11-23 16:51:40 +0100
commitd4e1dd97341468ca2772029335b95a420abe81ca (patch)
treeda22a1c1b26c35b65e6c108a279cc7e957c574ed /configure.ac
parent86a8f99806d0ed886e5833f85ed7fd6aea858167 (diff)
downloadgtk+-d4e1dd97341468ca2772029335b95a420abe81ca.tar.gz
open-with: add a PackageKit module for online lookup of applications
It's implemented with a GIOExtensionPoint, which has two implementations: - a dummy one, which just errors out - a PackageKit one, which looks up for the specified content type using the PK DBus API and GDBus. The PK module is optional, and can be compiled out at configure time. TODO: a Win32 implementation of the module.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3ac0bec577..c5d97ff4cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1489,6 +1489,25 @@ GLIB_GSETTINGS
GOBJECT_INTROSPECTION_CHECK([0.9.3])
##################################################
+# Packagekit module
+#################################################
+
+AC_ARG_ENABLE(packagekit,
+ AC_HELP_STRING([--disable-packagekit],
+ [build packagekit open with module]))
+
+ENABLE_PACKAGEKIT=
+if test "os_win32" != "yes"; then
+ if test "x$enable_packagekit" != "xno"; then
+ ENABLE_PACKAGEKIT=1
+ AC_DEFINE(ENABLE_PACKAGEKIT, 1, [define to enable packagekit])
+ fi
+fi
+
+AC_SUBST(ENABLE_PACKAGEKIT)
+AM_CONDITIONAL(ENABLE_PACKAGEKIT, test "x$ENABLE_PACKAGEKIT" = "x1")
+
+##################################################
# Checks for gtk-doc and docbook-tools
##################################################