summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2016-01-26 11:46:48 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2016-01-26 11:46:48 +0000
commitc8686f0c474ad96075938367ae9065105ed1e03f (patch)
tree48f61f902ff3df6a72f47f9c7b808987f12c2af0 /configure.ac
parent2a9967731a3b77b102ada633c39b5a35efc80957 (diff)
downloadgtk+-c8686f0c474ad96075938367ae9065105ed1e03f.tar.gz
demo: Link against Harfbuzz
The font features demo started calling the Harfbuzz API directly starting from commit 9de3b24c205f1c647292a490f92f21a776b931a4. Harfbuzz is an implicit dependency of Pango on some platforms, but it's not part of the public dependencies; this means that we cannot expect to link to Pango and automatically get Harfbuzz symbols to link against — especially when things like --as-needed are in play. This change triggered build failures on non-Unix platforms, fixed by commit 2a9967731a3b77b102ada633c39b5a35efc80957, as well as build failures in Continuous, with this error message: /usr/lib/gcc/x86_64-gnomeostree-linux/4.9.3/../../../../x86_64-gnomeostree-linux/bin/ld: font_features.o: undefined reference to symbol 'hb_tag_to_string' //lib/libharfbuzz.so.0: error adding symbols: DSO missing from command line collect2: error: ld returned 1 exit status In order to get the font features demo to build everywhere we should take an explicit, though optional, check on Harfbuzz, and conditionally build the font features demo with the right compiler and linker flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c15aaa933e..3ff4615596 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1691,6 +1691,15 @@ fi
AM_CONDITIONAL(HAVE_COLORD, test "x$have_colord" = "xyes")
##################################################
+# Check for harfbuzz
+##################################################
+
+PKG_CHECK_MODULES(HARFBUZZ, harfbuzz >= 0.9, have_harfbuzz=yes, have_harfbuzz=no)
+AC_SUBST(HARFBUZZ_CFLAGS)
+AC_SUBST(HARFBUZZ_LIBS)
+AM_CONDITIONAL(BUILD_FONT_DEMO, [ test "x$have_harfbuzz" = xyes ])
+
+##################################################
# Checks for gtk-doc and docbook-tools
##################################################