summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-15 13:09:24 +0200
committerMatthias Clasen <mclasen@redhat.com>2012-05-16 23:55:40 -0400
commitd6aee922bb5da8254fafdf605951cf5b0150537d (patch)
treef1b12f171204a8cf4c7ca13f78bf58856b6fb0ab /configure.ac
parent276dae8ae6a024259b32fc28bf72e9dbb08fe963 (diff)
downloadgtk+-d6aee922bb5da8254fafdf605951cf5b0150537d.tar.gz
Bug 676087-configure.ac: isnan() and isinf() are macros, not functions
The isnan() and isinf() are C99 macros not functions so use AC_CHECK_DECL instead of AC_CHECK_FUNCS for those.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 857d0158f8..c801dd2aa4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -751,7 +751,8 @@ AC_TYPE_UID_T
# Check for round(), rint(), isnan(), isinf() and nearbyint()
AC_CHECK_LIB(m,round,,)
-AC_CHECK_FUNCS(round rint isnan isinf nearbyint)
+AC_CHECK_FUNCS(round rint nearbyint)
+AC_CHECK_DECLS([isnan, isinf], [], [], [[#include <math.h>]])
# Checks for gdkspawn
AC_CHECK_HEADERS(crt_externs.h)