summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2011-01-14 20:01:05 -0500
committerMatthias Clasen <mclasen@redhat.com>2011-01-14 20:01:05 -0500
commit1cba79677cb8e9023a2a25568f6447bdc55747dc (patch)
tree4a27f6ee59d2199b92658c9b15dec26286e83183 /configure.ac
parentd8d31c60cab5af8a8749767f49ce8dfde5f037f9 (diff)
downloadgtk+-1cba79677cb8e9023a2a25568f6447bdc55747dc.tar.gz
Add --enable-gtk2-dependency option
This can be used to suppress building of gtk-update-icon-cache in favor of using a preexisting version. Based on a patch by Colin Walters, https://bugzilla.gnome.org/show_bug.cgi?id=639471
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f81468f811..d6bfe474de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,6 +242,13 @@ AC_ARG_ENABLE(rebuilds,
[disable all source autogeneration rules])],,
[enable_rebuilds=yes])
+AC_ARG_ENABLE(gtk2-dependency,
+ AC_HELP_STRING([--enable-gtk2-dependency],
+ [Do not build gtk-update-icon-cache and other shared tools]),,
+ [enable_gtk2_dependency=no])
+
+AM_CONDITIONAL(BUILD_ICON_CACHE, [test "x$enable_gtk2_dependency" = xno])
+
AC_ARG_ENABLE(xkb,
[AC_HELP_STRING([--enable-xkb],
[support XKB extension [default=maybe]])],,
@@ -875,13 +882,15 @@ dnl Look for a host system's gdk-pixbuf-csource if we are cross-compiling
AM_CONDITIONAL(CROSS_COMPILING, test $cross_compiling = yes)
-if test $cross_compiling = yes; then
+if test "x$cross_compiling" = xyes || test "x$enable_gtk2_dependency" = xyes; then
AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache, no)
if test x$GTK_UPDATE_ICON_CACHE = xno; then
REBUILD_PNGS=#
fi
fi
+AM_CONDITIONAL(USE_EXTERNAL_ICON_CACHE, [test "x$cross_compiling" = xyes || test "x$enable_gtk2_dependency" = xyes])
+
AC_PATH_PROG(GDK_PIXBUF_CSOURCE, gdk-pixbuf-csource, no)
if test ! -f $srcdir/gtk/gtkbuiltincache.h &&