summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Bradford <rob@linux.intel.com>2012-04-04 17:20:13 +0100
committerRob Bradford <rob@linux.intel.com>2012-04-16 15:09:14 +0100
commitcdf5c2af628a1ca202cd8c6a8d3529b46718183b (patch)
treeb3b1c3f36ab7394ab75d26507866547120948000 /configure.ac
parent6977ea0bd1aa91e757a08d2d6a8fcc2adb08588c (diff)
downloadgtk+-cdf5c2af628a1ca202cd8c6a8d3529b46718183b.tar.gz
wayland: Add support for rendering into an SHM buffer with Cairo image backend
The first version of this change included a bug that meant that if you don't compile for any other backend then it wouldn't search for cairo. Credit for identifying the bug goes to darxus@chaosreigns.com. Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=672361
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 93cf28125b..8e1d691ef6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -379,13 +379,16 @@ else
fi
if test "x$enable_wayland_backend" == "xyes"; then
- # Wayland uses cairo-gl
- cairo_backends="$cairo_backends cairo-gl"
+ # For the cairo image backend
+ cairo_backends="$cairo_backends cairo"
GDK_BACKENDS="$GDK_BACKENDS wayland"
have_gio_unix=yes
GDK_WINDOWING="$GDK_WINDOWING
#define GDK_WINDOWING_WAYLAND"
- WAYLAND_PACKAGES="wayland-client xkbcommon wayland-egl egl"
+ WAYLAND_PACKAGES="wayland-client xkbcommon "
+ if test "x$enable_wayland_cairo_gl" == "xyes"; then
+ WAYLAND_PACKAGES="$WAYLAND_PACKAGES wayland-egl egl"
+ fi
AM_CONDITIONAL(USE_WAYLAND, true)
else
AM_CONDITIONAL(USE_WAYLAND, false)