summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2013-10-06 15:32:18 -0400
committerMatthias Clasen <mclasen@redhat.com>2013-10-06 15:32:18 -0400
commitfe4fdeb7ae9b7d7fb6c10bf498a2b3c5b93730ca (patch)
tree573f6b776f1fd10dde92325722be23f7334b0979 /configure.ac
parentb6e8f274393b90a4ed0071afdbd445c7efd6f285 (diff)
downloadgtk+-fe4fdeb7ae9b7d7fb6c10bf498a2b3c5b93730ca.tar.gz
Fix build with explicit --enable-wayland-backend
We forgot to set set WAYLAND_SCANNER in this case.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index de92e7adda..73a2c479a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -419,6 +419,7 @@ if test "$enable_wayland_backend" = "yes"; then
#define GDK_WINDOWING_WAYLAND"
DISABLE_ON_WAYLAND='%'
WAYLAND_PACKAGES="$WAYLAND_DEPENDENCIES"
+ AC_PATH_PROG([WAYLAND_SCANNER],[wayland-scanner],[no])
AS_IF([test "x$WAYLAND_SCANNER" = "xno"],
AC_MSG_ERROR([Could not find wayland-scanner in your PATH, required for parsing wayland extension protocols]))
AC_SUBST([WAYLAND_SCANNER])