summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2015-02-02 16:02:04 +1000
committerMatthias Clasen <mclasen@redhat.com>2015-05-21 23:09:04 -0400
commite670720d196bac1cef6f88313f6514cdd8c4a0c5 (patch)
treed25709dbe300560439e2285eea7103ed5d922f9f /configure.ac
parent61cc10760d84f8600b6faf11046bb7b9a276e942 (diff)
downloadgtk+-e670720d196bac1cef6f88313f6514cdd8c4a0c5.tar.gz
gtk3: add randr 1.5 monitor support
This patch introduces support for using the newly introduced monitor objects in the XRandR protocol. These objects are meant to be used to denote a set of rectangles representing a logical monitor, and are used to hide details like monitor tiling and virtual gpu outputs. This uses the new objects instead of crtc/outputs objects when they are available to create the monitor lists. X server 1.18 is required on the server side for randr 1.5. https://bugzilla.gnome.org/show_bug.cgi?id=749561
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1f3185044f..106ff8ff34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1184,6 +1184,9 @@ if test "x$enable_x11_backend" = xyes; then
if $PKG_CONFIG --exists "xrandr >= 1.2.99" ; then
AC_DEFINE(HAVE_RANDR, 1, [Have the Xrandr extension library])
+ if $PKG_CONFIG --exists "xrandr >= 1.5.0" ; then
+ AC_DEFINE(HAVE_RANDR15, 1, [Have the Xrandr 1.5 extension library])
+ fi
X_PACKAGES="$X_PACKAGES xrandr"
X_EXTENSIONS="$X_EXTENSIONS XRANDR"
elif test x"$enable_xrandr" = xyes; then