summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2013-03-12 08:33:57 +0100
committerMatthias Clasen <mclasen@redhat.com>2013-03-12 07:20:18 -0400
commitd1de6c322b96d100ae37be92b5d5890897190661 (patch)
treeccb2bb082c9918e5f56e5deec0f3b020c4d4ec27 /configure.ac
parent1c796018d1dcba002766673c4070c9d98e95fadb (diff)
downloadgtk+-d1de6c322b96d100ae37be92b5d5890897190661.tar.gz
docs: Disable GtkPlug/GtkSocket docs on Wayland
As those two types do not exist in the Wayland backend, and the docs build would fail. https://bugzilla.gnome.org/show_bug.cgi?id=695682
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b90df72557..91e7da02d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -390,6 +390,7 @@ else
AM_CONDITIONAL(USE_BROADWAY, false)
fi
+DISABLE_ON_WAYLAND=''
if test "x$enable_wayland_backend" = "xyes"; then
# For the cairo image backend
cairo_backends="$cairo_backends cairo"
@@ -397,11 +398,13 @@ if test "x$enable_wayland_backend" = "xyes"; then
have_gio_unix=yes
GDK_WINDOWING="$GDK_WINDOWING
#define GDK_WINDOWING_WAYLAND"
+ DISABLE_ON_WAYLAND='%'
WAYLAND_PACKAGES="wayland-client >= 1.0.0 xkbcommon >= 0.2.0 wayland-cursor"
AM_CONDITIONAL(USE_WAYLAND, true)
else
AM_CONDITIONAL(USE_WAYLAND, false)
fi
+AC_SUBST(DISABLE_ON_WAYLAND)
# strip leading space
GDK_BACKENDS=${GDK_BACKENDS#* }