summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2012-04-05 18:15:45 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2012-05-03 11:54:41 +0800
commitc97f0b660c094d005844c0357df9bbc67c03861e (patch)
tree030202527c0b8580e3c5c592f49b5684c5181aab /configure.ac
parent2969db9993c7b00a17e279cf9c53543ae62fbed1 (diff)
downloadgtk+-c97f0b660c094d005844c0357df9bbc67c03861e.tar.gz
Bug 670499-configure.ac: Check for nearbyint(), isinf() and isnan()
nearbyint(), isinf() and isnan() are C99 functions, so check for them. Also clean up configure.ac a little bit as the checks for rint() and round() can be a bit simpler, according to Matthias' suggestions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 3 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index a87fb3f2b5..1ac1b23eff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -749,17 +749,9 @@ AC_CHECK_FUNCS(mallinfo)
AC_CHECK_FUNCS(getresuid)
AC_TYPE_UID_T
-# Check for round()
-AC_CHECK_LIB(m,round,have_round=yes,have_round=no)
-if test $have_round = yes; then
- AC_DEFINE(HAVE_ROUND, 1, [Define to 1 if round() is available])
-fi
-
-# Check for rint()
-AC_CHECK_LIB(m,rint,have_rint=yes,have_rint=no)
-if test $have_rint = yes; then
- AC_DEFINE(HAVE_RINT, 1, [Define to 1 if rint() is available])
-fi
+# Check for round(), rint(), isnan(), isinf() and nearbyint()
+AC_CHECK_LIB(m,round,,)
+AC_CHECK_FUNCS(round rint isnan isinf nearbyint)
# Checks for gdkspawn
AC_CHECK_HEADERS(crt_externs.h)