summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2011-06-10 12:34:40 +0100
committerRichard Hughes <richard@hughsie.com>2011-06-10 12:34:54 +0100
commit7a328b377c50a0ba527a497010216f42aec31b91 (patch)
tree17b520d477873617df6022e61102ab2c3246b68d /configure.ac
parent10ab6f357051f2f32bead9e2b5b435a6fd924f68 (diff)
downloadgtk+-7a328b377c50a0ba527a497010216f42aec31b91.tar.gz
If --enable-colord or --disable-colord is not used when configuring, autodetect the presence of colord
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 77a6cee5c7..22943e3a67 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1543,14 +1543,21 @@ AC_ARG_ENABLE(colord,
have_colord=no
if test "x$enable_colord" != "xno"; then
if test "os_win32" != "yes"; then
- PKG_CHECK_MODULES(COLORD, colord >= 0.1.9)
- have_colord=yes
- AC_DEFINE(HAVE_COLORD, 1, [define if we have colord])
+ PKG_CHECK_MODULES(COLORD, colord >= 0.1.9,
+ have_colord=yes, have_colord=no)
+ if test "enable_colord" = "yes"; then
+ if test "have_colord" = "no"; then
+ AC_MSG_ERROR([--enable-colord specified, but not available])
+ fi
+ fi
else
AC_MSG_ERROR([colord support is not available on win32])
fi
fi
+if test "have_colord" = "yes"; then
+ AC_DEFINE(HAVE_COLORD, 1, [define if we have colord])
+fi
AM_CONDITIONAL(HAVE_COLORD, test "x$have_colord" = "xyes")
##################################################