summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGiovanni Campagna <gcampagn@redhat.com>2013-08-30 13:55:37 +0200
committerGiovanni Campagna <gcampagn@redhat.com>2013-09-03 17:03:43 +0200
commitd34335e51c98efebe010bd4a202fe2a4b2fb7d06 (patch)
tree30030fb9dfba5c4fdd2df03c6aafc11c8896c6f7 /configure.ac
parente000ba468f518fab1bb9b00fe8cc53ccd0dbfed9 (diff)
downloadgtk+-d34335e51c98efebe010bd4a202fe2a4b2fb7d06.tar.gz
wayland: add support for a private gtk-shell protocol
This protocol will be used by mutter-wayland and gtk to replace the _GTK X11 properties for DBus names/paths. https://bugzilla.gnome.org/show_bug.cgi?id=707129
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 870d483a5d..90e162ac05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -404,6 +404,12 @@ if test "x$enable_wayland_backend" = "xyes"; then
#define GDK_WINDOWING_WAYLAND"
DISABLE_ON_WAYLAND='%'
WAYLAND_PACKAGES="wayland-client >= 1.1.90 xkbcommon >= 0.2.0 wayland-cursor"
+
+ AC_PATH_PROG([WAYLAND_SCANNER],[wayland-scanner],[no])
+ AS_IF([test "x$WAYLAND_SCANNER" = "xno"],
+ AC_MSG_ERROR([Could not find wayland-scanner in your PATH, required for parsing wayland extension protocols]))
+ AC_SUBST([WAYLAND_SCANNER])
+
AM_CONDITIONAL(USE_WAYLAND, true)
else
AM_CONDITIONAL(USE_WAYLAND, false)