summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2012-11-06 20:50:09 +0100
committerBenjamin Otte <otte@redhat.com>2012-11-06 21:29:58 +0100
commit58021c9e98bf7f5b584d0e0a9b23a0e72c7378b7 (patch)
treec771c3a95d8869ed212e5a7658117a1d3eb286a7 /configure.ac
parente9dc0e391d00cf39f27c053f08c4ce16bd2f8764 (diff)
downloadgtk+-58021c9e98bf7f5b584d0e0a9b23a0e72c7378b7.tar.gz
Disable deprecation checks for all libraries we depend on on stable branches.
This is so newer versions of those libraries don't cause more warnings with a stable GTK version. We don't ever want to turn off deprecation warnings for master however, because that's where we get rid of deprecated API we use. Note that only glib allows use to easily do this, so nothing is done for Pango, gdk-pixbuf or Cairo here.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 393892738e..cdf3c75a84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -714,7 +714,6 @@ AM_PATH_GLIB_2_0(glib_required_version, :,
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.]),
gobject gmodule-no-export)
-dnl
dnl Check for bind_textdomain_codeset, including -lintl if GLib brings it in.
dnl
gtk_save_LIBS=$LIBS
@@ -748,6 +747,19 @@ else
AC_MSG_RESULT([no])
fi
+#
+# Disable deprecation checks for all libraries we depend on on stable branches.
+# This is so newer versions of those libraries don't cause more warnings with
+# a stable GTK version.
+# We don't ever want to turn off deprecation warnings for master however, because
+# that's where we get rid of deprecated API we use.
+#
+if test m4_eval(gtk_minor_version % 2) = 0 ; then
+ AC_DEFINE_UNQUOTED(GLIB_DISABLE_DEPRECATION_WARNINGS, 1,
+ [Disable deprecation warnings from glib])
+fi
+
+dnl
saved_cflags="$CFLAGS"
saved_ldflags="$LDFLAGS"