summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2010-05-25 21:33:40 -0400
committerMatthias Clasen <mclasen@redhat.com>2010-05-25 21:33:40 -0400
commit0e1d84c954b374aa42b63a9bf64f080beae6400b (patch)
treece424e3665cf17ef11c938d17d60b3ad62812bca /configure.ac
parentcbab03df692c97b697c9984eae452195a30e0b02 (diff)
downloadgtk+-0e1d84c954b374aa42b63a9bf64f080beae6400b.tar.gz
Make gio sniffing test work again
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e4fa2428f1..cfd34706a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1092,9 +1092,10 @@ if test x$gio_can_sniff = x; then
{
char *content_type;
char *image_png;
+ g_type_init ();
content_type = g_content_type_guess (NULL, data, data_size, NULL);
image_png = g_content_type_from_mime_type ("image/png");
- return !!strcmp (content_type, image_png);
+ return !!g_strcmp0 (content_type, image_png);
}]])],
[gio_can_sniff=yes
AC_DEFINE(GDK_PIXBUF_USE_GIO_MIME, 1, [Define if gio can sniff image data])],