summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stef@memberwebs.com>2012-08-11 03:12:39 +0900
committerJavier Jardón <jjardon@gnome.org>2012-08-11 03:12:39 +0900
commit094fcd6fb7609361a864c6f3473791bf849c6bbc (patch)
treed8a6a7b9f1370bcd416c6cafcd7951e8018d6236 /configure.ac
parent374d48c37bdb93ba8d457c286f4ee15adcfe8b24 (diff)
downloadgtk+-094fcd6fb7609361a864c6f3473791bf849c6bbc.tar.gz
Allow building with CFLAGS=-Werror
Allow building using: $ CFLAGS=-Werror sh autogen.sh --prefix=/xxx
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6fea3afcc8..41e24a3928 100644
--- a/configure.ac
+++ b/configure.ac
@@ -987,11 +987,13 @@ if test "x$enable_x11_backend" = xyes; then
AC_MSG_CHECKING([if <X11/extensions/XIproto.h> is needed for xReply])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <X11/Xlibint.h>]],
- [[xReply *rep;]])],
+ [[xReply *rep = NULL;
+ rep = rep;]])],
[AC_MSG_RESULT([no])],
[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <X11/extensions/XIproto.h>
#include <X11/Xlibint.h>]],
- [[xReply *rep;]])],
+ [[xReply *rep = NULL;
+ rep = rep;]])],
[AC_MSG_RESULT([yes])
AC_DEFINE([NEED_XIPROTO_H_FOR_XREPLY], [1],
[Define if <X11/extensions/XIproto.h> needed for xReply])],