summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-12 17:27:53 +0200
committerMatthias Clasen <mclasen@redhat.com>2014-07-20 01:41:03 -0400
commitb441d3a736e0efc916172cfeea538d063b507611 (patch)
treeb8ca514700ac483f3628ce822de8205c36b7b7da /configure.ac
parent85297367dc5b4c10d2298566c203c2812b64b12c (diff)
downloadgtk+-b441d3a736e0efc916172cfeea538d063b507611.tar.gz
Use AC_PATH_TOOL to find build tools.
This improves support for cross-compilation & multilib on Gentoo, where tools proper for target arch/ABI are prefixed with CHOST. https://bugzilla.gnome.org/show_bug.cgi?id=731582
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index df5dbea8f4..d959ddec71 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,7 +228,7 @@ LT_OUTPUT
AC_SYS_LARGEFILE
AM_PROG_AS
-AC_PATH_PROG(NM, nm, nm)
+AC_PATH_TOOL(NM, nm, nm)
AC_MSG_CHECKING([for some Win32 platform])
case "$host" in
@@ -1444,7 +1444,7 @@ AC_ARG_ENABLE(cups,
if test "x$enable_cups" = "xno"; then
AM_CONDITIONAL(HAVE_CUPS, false)
else
- AC_PATH_PROG(CUPS_CONFIG, cups-config, no)
+ AC_PATH_TOOL(CUPS_CONFIG, cups-config, no)
if test "x$CUPS_CONFIG" = "xno"; then
if test "x$enable_cups" = "xauto"; then
AM_CONDITIONAL(HAVE_CUPS, false)