summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2014-07-02 13:15:01 +0100
committerMatthias Clasen <mclasen@redhat.com>2014-10-13 10:43:31 -0400
commit892c6bd6f9644014fab0fe9c90b69f58258da232 (patch)
treeada8d70c1a31b9a926c9197667056165a2d36d3e /configure.ac
parent493aa4e9b3b7ef673a3f0a7b49a6416e9ad8c5c2 (diff)
downloadgtk+-892c6bd6f9644014fab0fe9c90b69f58258da232.tar.gz
build: Require libepoxy
If we want to use OpenGL in GDK then we have two choices; either: - find the GL headers on each platform - do extension discovery - implement all the crazy dlopen()/dlsym() dispatch tables *or* use libepoxy, which shields us from all this madness and provides a decent layer for GL clients to use, without creating its own namespace. Epoxy is also used by other projects, like Xorg and piglit, and it's portable to all the platforms GDK cares about. https://bugzilla.gnome.org/show_bug.cgi?id=119189
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 65de7fc2ed..7927b39760 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,7 @@ m4_define([cairo_required_version], [1.12.0])
m4_define([gdk_pixbuf_required_version], [2.30.0])
m4_define([introspection_required_version], [1.39.0])
m4_define([wayland_required_version], [1.5.91])
+m4_define([epoxy_required_version], [1.0])
GLIB_REQUIRED_VERSION=glib_required_version
PANGO_REQUIRED_VERSION=pango_required_version
ATK_REQUIRED_VERSION=atk_required_version
@@ -1326,7 +1327,7 @@ CFLAGS="$saved_cflags"
LDFLAGS="$saved_ldflags"
GDK_PACKAGES="$PANGO_PACKAGES gdk-pixbuf-2.0 >= gdk_pixbuf_required_version cairo >= cairo_required_version cairo-gobject >= cairo_required_version"
-GDK_PRIVATE_PACKAGES="$GDK_GIO_PACKAGE $X_PACKAGES $WAYLAND_PACKAGES $cairo_backends"
+GDK_PRIVATE_PACKAGES="$GDK_GIO_PACKAGE $X_PACKAGES $WAYLAND_PACKAGES $cairo_backends epoxy >= epoxy_required_version"
if test "x$enable_x11_backend" = xyes; then
GDK_PRIVATE_PACKAGES="$GDK_PRIVATE_PACKAGES pangoft2"
fi