summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-05-06 21:55:41 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-05-06 21:55:41 +0000
commit629a0e14248812e55e9245bad9e01d9bc6bd2d0a (patch)
tree4805be6ed3f1fab22e7f536861e8e4f896e63b2c /Makefile.am
parent2e58122c793a66f6241ff4bfe74e8966a043eeb3 (diff)
downloadgtk+-629a0e14248812e55e9245bad9e01d9bc6bd2d0a.tar.gz
Patch from James Henstridge to update to automake-1.7 (#109542)
Tue May 6 16:50:52 2003 Owen Taylor <otaylor@redhat.com> Patch from James Henstridge to update to automake-1.7 (#109542) * autogen.sh: update to call newer tools. * configure.in: various updates, to use M4 macros to put variables that change each release at the top. Use AC_HELP_STRING to format help strings. Use AC_CONFIG_COMMANDS to generate gdkconfig.h. * Makefile.am: require Automake 1.7. Remove gdk-2.0.pc and gtk+-2.0.pc on uninstall. Pass --enable-gtk-doc to configure during distcheck. * docs/reference/*/Makefile.am: simplify to use the gtk-doc.make makefile fragment. * */Makefile.am: don't use STRIP_BEGIN/STRIP_END. Use BUILT_SOURCES where appropriate. Build generated files in builddir rather than srcdir. Fix uninstall and distclean targets to satisfy distcheck. === * gdk/*/Makefile.am: Remove the hacks to get gdkenumtypes.h built first, since we are now using BUILT_SOURCES. * gdk/Makefile.am: Remove an outdated comment about gdk_headers. * demos/gtk-demo/Makefile.am: Fix srcdir != buildd problem with geninclude.pl. * configure.in: Update versions to 2.3.0.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 6 insertions, 24 deletions
diff --git a/Makefile.am b/Makefile.am
index f9654c4cd3..077c32cb09 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos tests contrib
SUBDIRS = po $(SRC_SUBDIRS) docs build m4macros
# require automake 1.4
-AUTOMAKE_OPTIONS = 1.4
+AUTOMAKE_OPTIONS = 1.7
EXTRA_DIST = \
HACKING \
@@ -148,6 +148,10 @@ install-data-hook:
rm -f gdk-2.0.pc && cp -f gdk-$(GDKTARGET)-2.0.pc gdk-2.0.pc && \
rm -f gtk+-2.0.pc && cp -f gtk+-$(GDKTARGET)-2.0.pc gtk+-2.0.pc)
+uninstall-local:
+ rm -f $(DESTDIR)$(pkgconfigdir)/gdk-2.0.pc
+ rm -f $(DESTDIR)$(pkgconfigdir)/gtk+-2.0.pc
+
dist-hook:
if test -f $(srcdir)/INSTALL.in && test -f $(srcdir)/README.in ; then \
CONFIG_FILES="INSTALL:$(srcdir)/INSTALL.in README:$(srcdir)/README.in" \
@@ -181,26 +185,4 @@ snapshot:
$(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
-# This is a version of the automake-1.4 distcheck rule modified
-# to pass --enable-gtk-doc to ./configure
-#
-mydistcheck: dist
- -rm -rf $(distdir)
- GZIP=$(GZIP_ENV) $(TAR) zxf $(distdir).tar.gz
- mkdir $(distdir)/=build
- mkdir $(distdir)/=inst
- dc_install_base=`cd $(distdir)/=inst && pwd`; \
- cd $(distdir)/=build \
- && ../configure --srcdir=.. --prefix=$$dc_install_base --enable-gtk-doc \
- && $(MAKE) $(AM_MAKEFLAGS) \
- && $(MAKE) $(AM_MAKEFLAGS) dvi \
- && $(MAKE) $(AM_MAKEFLAGS) check \
- && $(MAKE) $(AM_MAKEFLAGS) install \
- && $(MAKE) $(AM_MAKEFLAGS) installcheck \
- && $(MAKE) $(AM_MAKEFLAGS) dist
- -rm -rf $(distdir)
- @banner="$(distdir).tar.gz is ready for distribution"; \
- dashes=`echo "$$banner" | sed s/./=/g`; \
- echo "$$dashes"; \
- echo "$$banner"; \
- echo "$$dashes"
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc