summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2010-12-10 14:44:50 -0500
committerMatthias Clasen <mclasen@redhat.com>2010-12-21 12:06:57 -0500
commitfa4b54b6de4156403f413b95bdb48ab4bd9e20a4 (patch)
tree143b4831afd36fccce40cb4f7793fff5ca29471f /Makefile.am
parent9a1cc81acbeff9984b69bc0d7cbd65d10705e654 (diff)
downloadgtk+-fa4b54b6de4156403f413b95bdb48ab4bd9e20a4.tar.gz
Add per-target pc files back
Dropping those will be an unnecessary pain.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 68002d7745..c95b0e685a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,9 +54,21 @@ MAINTAINERCLEANFILES = \
$(srcdir)/ChangeLog \
`find "$(srcdir)" -type f -name Makefile.in -print`
+
+## Copy .pc files to target-specific names
+gtk+-x11-3.0.pc gtk+-win32-3.0.pc gtk+-quartz-3.0.pc: gtk+-3.0.pc
+ rm -f $@ && \
+ cp gtk+-3.0.pc $@
+
+gtk+-*-3.0-uninstalled.pc: gtk+-3.0-uninstalled.pc
+ rm -f $@ && \
+ cp gtk+-3.0-uninstalled.pc $@
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gtk+-3.0.pc gail-3.0.pc
+pkgconfig_DATA += $(patsubst %,gtk+-%-3.0.pc,@gdktarget@)
+
if OS_UNIX
pkgconfig_DATA += gtk+-unix-print-3.0.pc
endif