summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2009-04-03 02:00:48 -0400
committerMatthias Clasen <mclasen@redhat.com>2009-04-03 02:00:48 -0400
commit4774d9c1fd46aca800add140c30ece5bf7a12d3a (patch)
treed4c00623b3ae688524633ec58ca47a1bacc08988 /Makefile.am
parente7b496719e54536b0c5403d16fea4da27d9c25e2 (diff)
downloadgtk+-4774d9c1fd46aca800add140c30ece5bf7a12d3a.tar.gz
Add a rule to generate ChangeLog
We use the same rule pango uses to create a ChangeLog file with the help of git-log. The format is somewhat different from traditional ChangeLog, but it contains the relevant information.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3fdb9f2706..e1bd48e8ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,9 @@ EXTRA_DIST += \
ChangeLog.pre-2-6 \
ChangeLog.pre-2-8 \
ChangeLog.pre-2-10 \
+ ChangeLog.pre-2-12 \
+ ChangeLog.pre-2-14 \
+ ChangeLog.pre-2-16 \
ChangeLog.gtk-async-file-chooser \
ChangeLog.gtk-printing \
README.commits \
@@ -152,6 +155,20 @@ DISTCLEANFILES = \
gail-uninstalled.pc \
config.lt
+ChangeLog:
+ @echo Creating $@
+ @if test -d "$(srcdir)/.git"; then \
+ (GIT_DIR=$(top_srcdir)/.git ./missing --run git log GTK_2_16_0^^.. --stat) | fmt --split-only > $@.tmp \
+ && mv -f $@.tmp $@ \
+ || ($(RM) $@.tmp; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log is required to generate this file >> $@); \
+ fi
+
## copy the default target for this platform to gdk-2.0.pc and gtk+-2.0.pc
DEFAULT_GDKTARGET=x11
install-data-hook:
@@ -176,7 +193,7 @@ dist-hook:
&& cp INSTALL README $(distdir) ; \
fi
-.PHONY: files release sanity snapshot
+.PHONY: files release sanity snapshot ChangeLog
files:
@files=`ls $(DISTFILES) 2> /dev/null `; for p in $$files; do \