summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2011-01-03 10:45:37 -0500
committerKristian Høgsberg <krh@bitplanet.net>2011-01-03 11:59:45 -0500
commitcacee7e7a380ac9009fc1339a860f563ebe4dc4d (patch)
tree17e127046551f6187434eba5e27f99307f376524 /Makefile.am
parentae7e5fc2d19445ba55832888adcc7c24aeb17323 (diff)
downloadgtk+-cacee7e7a380ac9009fc1339a860f563ebe4dc4d.tar.gz
configure.ac: Support multiple GDK backends in one build
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 107985ab0f..1063b9fb2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -71,8 +71,8 @@ gtk+-*-3.0-uninstalled.pc: gtk+-3.0-uninstalled.pc
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gdk-3.0.pc gtk+-3.0.pc gail-3.0.pc
-pkgconfig_DATA += $(patsubst %,gtk+-%-3.0.pc,@gdktarget@)
-pkgconfig_DATA += $(patsubst %,gdk-%-3.0.pc,@gdktarget@)
+pkgconfig_DATA += ${GDK_BACKENDS:%=gtk+-%-3.0.pc}
+pkgconfig_DATA += ${GDK_BACKENDS:%=gdk-%-3.0.pc}
if OS_UNIX
pkgconfig_DATA += gtk+-unix-print-3.0.pc