summaryrefslogtreecommitdiff
path: root/gst/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/Makefile.am')
-rw-r--r--gst/Makefile.am33
1 files changed, 14 insertions, 19 deletions
diff --git a/gst/Makefile.am b/gst/Makefile.am
index 60d4b11a02..dcb8c93e2a 100644
--- a/gst/Makefile.am
+++ b/gst/Makefile.am
@@ -1,11 +1,5 @@
lib_LTLIBRARIES = libgstreamer-@GST_MAJORMINOR@.la
-if GST_DISABLE_LOADSAVE
-GST_LOADSAVE_SRC =
-else
-GST_LOADSAVE_SRC = gstxml.c
-endif
-
if GST_DISABLE_REGISTRY
GST_REGISTRY_SRC =
else
@@ -44,7 +38,7 @@ built_header_make = gstenumtypes.h gstmarshal.h
built_source_make = gstenumtypes.c gstmarshal.c
EXTRA_libgstreamer_@GST_MAJORMINOR@_la_SOURCES = \
- gstmarshal.list gsttrace.c gstxml.c \
+ gstmarshal.list gsttrace.c \
gstregistrybinary.c
@@ -57,6 +51,7 @@ libgstreamer_@GST_MAJORMINOR@_la_SOURCES = \
gstbin.c \
gstbuffer.c \
gstbufferlist.c \
+ gstbufferpool.c \
gstbus.c \
gstcaps.c \
gstchildproxy.c \
@@ -73,10 +68,11 @@ libgstreamer_@GST_MAJORMINOR@_la_SOURCES = \
gstindex.c \
gstindexfactory.c \
gstinfo.c \
- gstinterface.c \
gstiterator.c \
gstatomicqueue.c \
gstmessage.c \
+ gstmeta.c \
+ gstmemory.c \
gstminiobject.c \
gstpad.c \
gstpadtemplate.c \
@@ -105,8 +101,7 @@ libgstreamer_@GST_MAJORMINOR@_la_SOURCES = \
gstutils.c \
gstvalue.c \
gstparse.c \
- $(GST_REGISTRY_SRC) \
- $(GST_LOADSAVE_SRC)
+ $(GST_REGISTRY_SRC)
# do not put files in the distribution that are generated
nodist_libgstreamer_@GST_MAJORMINOR@_la_SOURCES = $(built_source_make)
@@ -134,7 +129,6 @@ libgstreamer_@GST_MAJORMINOR@_la_LIBADD = \
$(GST_PARSE_LA) \
$(GST_ALL_LIBS) \
$(WIN32_LIBS) \
- $(XML_LIBS) \
$(LIBM)
libgstreamer_@GST_MAJORMINOR@_la_LDFLAGS = \
@@ -149,6 +143,7 @@ gst_headers = \
gstbin.h \
gstbuffer.h \
gstbufferlist.h \
+ gstbufferpool.h \
gstbus.h \
gstcaps.h \
gstchildproxy.h \
@@ -157,6 +152,7 @@ gst_headers = \
gstdatetime.h \
gstdebugutils.h \
gstelement.h \
+ gstelementmetadata.h \
gstelementfactory.h \
gsterror.h \
gstevent.h \
@@ -166,11 +162,12 @@ gst_headers = \
gstindex.h \
gstindexfactory.h \
gstinfo.h \
- gstinterface.h \
gstiterator.h \
gstatomicqueue.h \
gstmacros.h \
gstmessage.h \
+ gstmeta.h \
+ gstmemory.h \
gstminiobject.h \
gstpad.h \
gstpadtemplate.h \
@@ -195,8 +192,7 @@ gst_headers = \
gstutils.h \
gstvalue.h \
gstregistry.h \
- gstparse.h \
- gstxml.h
+ gstparse.h
libgstreamer_@GST_MAJORMINOR@include_HEADERS = $(gst_headers) math-compat.h
@@ -208,7 +204,7 @@ noinst_HEADERS = \
glib-compat-private.h \
gst-i18n-lib.h \
gst-i18n-app.h \
- gstelementdetails.h \
+ gstelementmetadata.h \
gstpluginloader.h \
gstquark.h \
gstregistrybinary.h \
@@ -278,19 +274,18 @@ Gst-@GST_MAJORMINOR@.gir: $(INTROSPECTION_SCANNER) libgstreamer-@GST_MAJORMINOR@
-I$(top_srcdir) \
-I$(top_builddir) \
-DIN_GOBJECT_INTROSPECTION=1 \
+ -DGST_USE_UNSTABLE_API \
--c-include='gst/gst.h' \
- --library=libgstreamer-0.10.la \
+ --library=libgstreamer-0.11.la \
--include=GLib-2.0 \
--include=GObject-2.0 \
--include=GModule-2.0 \
- --include=libxml2-2.0 \
--libtool="$(top_builddir)/libtool" \
--pkg glib-2.0 \
--pkg gobject-2.0 \
--pkg gmodule-no-export-2.0 \
--pkg gthread-2.0 \
- --pkg libxml-2.0 \
- --pkg-export gstreamer-0.10 \
+ --pkg-export gstreamer-@GST_MAJORMINOR@ \
--add-init-section="gst_init(NULL, NULL);" \
--output $@ \
$(gir_headers) \