summaryrefslogtreecommitdiff
path: root/gst/autodetect/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gst/autodetect/meson.build')
-rw-r--r--gst/autodetect/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/gst/autodetect/meson.build b/gst/autodetect/meson.build
new file mode 100644
index 000000000..4512d2b83
--- /dev/null
+++ b/gst/autodetect/meson.build
@@ -0,0 +1,16 @@
+autodetect_sources = [
+ 'gstautoaudiosink.c',
+ 'gstautoaudiosrc.c',
+ 'gstautodetect.c',
+ 'gstautovideosink.c',
+ 'gstautovideosrc.c',
+]
+
+gstautodetect = library('gstautodetect',
+ autodetect_sources,
+ c_args : gst_plugins_good_args,
+ include_directories : [configinc],
+ dependencies : [gst_dep],
+ install : true,
+ install_dir : plugins_install_dir,
+)