summaryrefslogtreecommitdiff
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorStefan Sauer <ensonic@users.sf.net>2014-02-19 21:01:39 +0100
committerStefan Sauer <ensonic@users.sf.net>2014-02-19 21:07:28 +0100
commitce683b0031835e6b2e7a844ec7884d15adf997a6 (patch)
tree99cd2ed2b31d62a2110671ad26e2a609f686d5bc /tests/check/Makefile.am
parent6f1d4da8b43b2392a0c7df3feb2daaa7e7c45964 (diff)
downloadgstreamer-plugins-good-ce683b0031835e6b2e7a844ec7884d15adf997a6.tar.gz
autodetect: improve the tests
Add fake audio/video sinks. Previously running the test might be flaky due to the use of real elements (hardware in use), which we don't want to test here. Add two more tests that check that the fakes are chosen.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 9c3e13592..bf49ee6ea 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -245,6 +245,9 @@ elements_audiowsincband_LDADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_API_VE
elements_audiowsinclimit_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(CFLAGS) $(AM_CFLAGS)
elements_audiowsinclimit_LDADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_API_VERSION) $(LDADD)
+elements_autodetect_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(CFLAGS) $(AM_CFLAGS)
+elements_autodetect_LDADD = $(GST_BASE_LIBS) $(LDADD)
+
elements_equalizer_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(CFLAGS) $(AM_CFLAGS)
elements_equalizer_LDADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_API_VERSION) $(LDADD)