summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2019-12-10 23:48:35 +0900
committerSeungha Yang <seungha.yang@navercorp.com>2019-12-10 23:48:35 +0900
commit5009cad2200c04a6f8845ad0e661ad6a91bc7d83 (patch)
tree4765d9a304933e5424f801a956709f5d23d1365e /meson.build
parentb44d37a3387398a134140a4caa64919e95f7f7e3 (diff)
downloadgstreamer-plugins-good-5009cad2200c04a6f8845ad0e661ad6a91bc7d83.tar.gz
flvmux: Use thread-safe gmtime_r if available
gmtime on *nix is not thread-safe.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b4f338ade..28df2fcd2 100644
--- a/meson.build
+++ b/meson.build
@@ -151,6 +151,7 @@ check_functions = [
# check token HAVE_RDTSC
['HAVE_SINH', 'sinh', '#include<math.h>'],
# check token HAVE_WAVEFORM
+ ['HAVE_GMTIME_R', 'gmtime_r', '#include<time.h>'],
]
libm = cc.find_library('m', required : false)