summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2020-07-02 07:53:14 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2020-07-02 07:53:14 +0530
commitc7f8c8d4ef3432da6222e94453c7651d5cba204f (patch)
tree194dc579a6b414c39593516962ab40d68650997b /meson.build
parent3fe4626e3c344db38d4f8de6e5075018010afe7e (diff)
downloadgstreamer-plugins-good-c7f8c8d4ef3432da6222e94453c7651d5cba204f.tar.gz
deinterlace: Disable nasm support on x32
The assembly assumes pointers are 64-bit, so just disable it. Closes https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues/757 Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/merge_requests/660>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8822de5b1..509fb8c73 100644
--- a/meson.build
+++ b/meson.build
@@ -341,6 +341,8 @@ host_cpu = host_machine.cpu_family()
if host_cpu == 'x86_64'
if cc.get_id() == 'msvc'
message('Nasm disabled on MSVC')
+ elif cc.get_define('__ILP32__') == '1'
+ message('Nasm disabled on x32')
else
asm_option = get_option('asm')
nasm = find_program('nasm', native: true, required: asm_option)