summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-05-05 19:27:24 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-05-05 20:31:01 +0530
commit65536f25dd0e5b359faef63e143ed36ac076264d (patch)
treef06827ca18237a9451e8938c0afaaa576aa76507 /meson.build
parent36e49fd6f872f0b3f33083107a55fb7f671a47d0 (diff)
downloadgstreamer-plugins-good-65536f25dd0e5b359faef63e143ed36ac076264d.tar.gz
meson: Update option names to omit disable_ and with- prefixes
Also yield common options to the outer project (gst-build in our case) so that they don't have to be set manually.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 29f8a5e0e..50c399eab 100644
--- a/meson.build
+++ b/meson.build
@@ -187,7 +187,7 @@ foreach extra_arg : warning_c_flags
endforeach
# GStreamer package name and origin url
-gst_package_name = get_option('with-package-name')
+gst_package_name = get_option('package-name')
if gst_package_name == ''
if gst_version_nano == 0
gst_package_name = 'GStreamer Good Plug-ins source release'
@@ -198,7 +198,7 @@ if gst_package_name == ''
endif
endif
cdata.set_quoted('GST_PACKAGE_NAME', gst_package_name)
-cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('with-package-origin'))
+cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('package-origin'))
# Mandatory GST deps
gst_dep = dependency('gstreamer-1.0', version : gst_req,
@@ -314,8 +314,8 @@ libsinc = include_directories('gst-libs')
have_orcc = false
orcc_args = []
-if get_option('use_orc') != 'no'
- need_orc = get_option('use_orc') == 'yes'
+if get_option('orc') != 'no'
+ need_orc = get_option('orc') == 'yes'
# Used by various libraries/elements that use Orc code
orc_dep = dependency('orc-0.4', version : '>= 0.4.17', required : need_orc)
orcc = find_program('orcc', required : need_orc)
@@ -334,7 +334,7 @@ endif
if gst_dep.type_name() == 'internal'
gst_proj = subproject('gstreamer')
- if gst_proj.get_variable('disable_gst_debug')
+ if not gst_proj.get_variable('gst_debug')
message('GStreamer debug system is disabled')
add_project_arguments('-Wno-unused', language: 'c')
else