summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-09-01 09:30:23 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-09-01 09:30:23 +0530
commit5ca7a02371dda95481c151edd2a0ddd9753cfa77 (patch)
tree71151c4c7ed510d92457d2f6a16f84fe732c7c3d /meson.build
parent66351255f7491a066ac69c49bf6f3bff6d35cd88 (diff)
downloadgstreamer-plugins-good-5ca7a02371dda95481c151edd2a0ddd9753cfa77.tar.gz
meson: Fix osxaudio build on iOS
Must define HAVE_IOS, and use appleframeworks dependency to ensure the right frameworks are picked up.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d861fdfe4..a37c7c4e4 100644
--- a/meson.build
+++ b/meson.build
@@ -134,7 +134,6 @@ check_functions = [
['HAVE_GETPAGESIZE', 'getpagesize', '#include<unistd.h>'],
# check token HAVE_GETTEXT
# check token HAVE_GST_V4L2
-# check token HAVE_IOS
['HAVE_ISINF', 'isinf', '#include<math.h>'],
# check token HAVE_LIBV4L2
['HAVE_MMAP', 'mmap', '#include<sys/mman.h>'],
@@ -154,6 +153,8 @@ foreach f : check_functions
endif
endforeach
+cdata.set('HAVE_IOS', host_system == 'ios')
+
cdata.set('SIZEOF_CHAR', cc.sizeof('char'))
cdata.set('SIZEOF_INT', cc.sizeof('int'))
cdata.set('SIZEOF_LONG', cc.sizeof('long'))