summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorVivia Nikolaidou <vivia@ahiru.eu>2020-06-16 11:52:38 +0300
committerVivia Nikolaidou <vivia@ahiru.eu>2020-06-16 12:53:25 +0300
commit536ff4776fa424ee24f374b7e0461cba232923c6 (patch)
tree816f0dce5b2ff9bd3c0a4643728896e86d58bd1f /meson.build
parentef78014d15bf3e0f39a9572b57caae5dcc21f133 (diff)
downloadgstreamer-plugins-good-536ff4776fa424ee24f374b7e0461cba232923c6.tar.gz
deinterlace: Add yadif ASM optimisations
Measured to be about 3.4x faster than C Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/merge_requests/621>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7461fd9c4..4469c5eb7 100644
--- a/meson.build
+++ b/meson.build
@@ -335,6 +335,22 @@ else
cdata.set('DISABLE_ORC', 1)
endif
+have_nasm=false
+# FIXME: nasm path needs testing on non-Linux, esp. Windows
+host_cpu = host_machine.cpu_family()
+if host_cpu == 'x86_64'
+ if cc.get_id() == 'msvc'
+ message('Nasm disabled on MSVC')
+ else
+ nasm = find_program('nasm', native: true, version : '>= 2.13', required: get_option('asm'))
+ if nasm.found()
+ message('Nasm found on x86-64')
+ cdata.set('HAVE_NASM', 1)
+ have_nasm = true
+ endif
+ endif
+endif
+
# Disable compiler warnings for unused variables and args if gst debug system is disabled
if gst_dep.type_name() == 'internal'
gst_debug_disabled = not subproject('gstreamer').get_variable('gst_debug')
@@ -378,6 +394,7 @@ if find_program('xgettext', required : get_option('nls')).found()
subdir('po')
endif
+cdata.set10('ARCH_X86_64', host_cpu == 'x86_64')
configure_file(output : 'config.h', configuration : cdata)
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')