summaryrefslogtreecommitdiff
path: root/ext/opus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/opus/Makefile.am')
-rw-r--r--ext/opus/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/ext/opus/Makefile.am b/ext/opus/Makefile.am
index c64369252..27ae39d91 100644
--- a/ext/opus/Makefile.am
+++ b/ext/opus/Makefile.am
@@ -1,6 +1,6 @@
plugin_LTLIBRARIES = libgstopus.la
-libgstopus_la_SOURCES = gstopus.c gstopusdec.c gstopusenc.c gstopusparse.c gstopusheader.c gstopuscommon.c gstrtpopuspay.c gstrtpopusdepay.c
+libgstopus_la_SOURCES = gstopus.c gstopusdec.c gstopusenc.c gstopusheader.c gstopuscommon.c
libgstopus_la_CFLAGS = \
-DGST_USE_UNSTABLE_API \
$(GST_PLUGINS_BAD_CFLAGS) \
@@ -8,13 +8,13 @@ libgstopus_la_CFLAGS = \
$(GST_CFLAGS) \
$(OPUS_CFLAGS)
libgstopus_la_LIBADD = \
- $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_API_VERSION) \
- -lgsttag-$(GST_API_VERSION) -lgstrtp-$(GST_API_VERSION) \
- -lgstpbutils-$(GST_API_VERSION) \
+ $(top_builddir)/gst-libs/gst/tag/libgsttag-$(GST_API_VERSION).la \
+ $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-$(GST_API_VERSION).la \
+ $(top_builddir)/gst-libs/gst/audio/libgstaudio-$(GST_API_VERSION).la \
$(GST_BASE_LIBS) \
$(GST_LIBS) \
$(OPUS_LIBS)
libgstopus_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(LIBM)
libgstopus_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
-noinst_HEADERS = gstopusenc.h gstopusdec.h gstopusparse.h gstopusheader.h gstopuscommon.h gstrtpopuspay.h gstrtpopusdepay.h
+noinst_HEADERS = gstopusenc.h gstopusdec.h gstopusheader.h gstopuscommon.h