summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2015-12-21 00:43:49 +0100
committerSebastian Dröge <sebastian@centricular.com>2015-12-21 12:27:58 +0100
commitd08b96b0b7070b5b094663ce6f3d014ca5cf8d67 (patch)
tree3ca69279f9c14d77963faf1822f82d4b9d1f2238 /configure.ac
parentd43f1b2a5a4361f156ab1281f7e4442a899d4de7 (diff)
downloadgstreamer-plugins-base-d08b96b0b7070b5b094663ce6f3d014ca5cf8d67.tar.gz
configure: Make -Bsymbolic check work with clang.
Update the -Bsymbolic check with the version glib has. This version works with clang. https://bugzilla.gnome.org/show_bug.cgi?id=759713
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5e7ea8578..d3302d596 100644
--- a/configure.ac
+++ b/configure.ac
@@ -347,15 +347,16 @@ dnl Check for -Bsymbolic-functions linker flag used to avoid
dnl intra-library PLT jumps, if available.
AC_ARG_ENABLE(Bsymbolic,
[AS_HELP_STRING([--disable-Bsymbolic],[avoid linking with -Bsymbolic])],,
- [SAVED_LDFLAGS="${LDFLAGS}"
+ [SAVED_LDFLAGS="${LDFLAGS}" SAVED_LIBS="${LIBS}"
AC_MSG_CHECKING([for -Bsymbolic-functions linker flag])
LDFLAGS=-Wl,-Bsymbolic-functions
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[int main (void) { return 0; }]])],[
+ LIBS=
+ AC_TRY_LINK([], [return 0],
AC_MSG_RESULT(yes)
- enable_Bsymbolic=yes],[
+ enable_Bsymbolic=yes,
AC_MSG_RESULT(no)
- enable_Bsymbolic=no])
- LDFLAGS="${SAVED_LDFLAGS}"])
+ enable_Bsymbolic=no)
+ LDFLAGS="${SAVED_LDFLAGS}" LIBS="${SAVED_LIBS}"])
dnl *** set variables based on configure arguments ***