summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2014-08-12 16:17:11 +0300
committerSebastian Dröge <sebastian@centricular.com>2014-08-12 16:17:38 +0300
commit9efc92a3a1b560e2598f52c03346bfb4f18f3300 (patch)
tree0a8e72680b2adeb3fef0cf7423deedbdc9374665 /configure.ac
parente972365887d1e4aeaf21f879ab90ea026f9475d6 (diff)
downloadgst-libav-9efc92a3a1b560e2598f52c03346bfb4f18f3300.tar.gz
libav: Minor changes to build properly with v11alpha1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 229ea9b..64be10b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -246,7 +246,7 @@ AC_ARG_WITH(system-libav,
[AC_HELP_STRING([--with-system-libav], [use system Libav libraries])])
if test "x$with_system_libav" = "xyes"; then
- PKG_CHECK_MODULES(LIBAV, libavformat libavcodec libavutil)
+ PKG_CHECK_MODULES(LIBAV, libavformat libavcodec libavresample libavutil)
PKG_CHECK_MODULES(SWSCALE, libswscale libavutil)
saved_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $LIBAV_CFLAGS"
@@ -265,12 +265,13 @@ else
LIBAV_DEPS="\$(top_builddir)/gst-libs/ext/libav/libavformat/libavformat.a \
\$(top_builddir)/gst-libs/ext/libav/libavcodec/libavcodec.a \
+ \$(top_builddir)/gst-libs/ext/libav/libavresample/libavresample.a \
\$(top_builddir)/gst-libs/ext/libav/libavutil/libavutil.a"
if test "x$enable_static_plugins" = xyes; then
dnl with static linking we can't use the .a archive directly as they would
dnl be included in the final libgstlibav.a as a file and won't be usable.
dnl libav*.a must be copied to the final destination too
- LIBAV_LIBS="-lavformat -lavcodec -lavutil"
+ LIBAV_LIBS="-lavformat -lavcodec -lavresample -lavutil"
else
dnl libgstlibav.la: libs to statically link to
LIBAV_LIBS="$LIBAV_DEPS"