summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlain Magloire <alainm@rcsm.ee.mcgill.ca>2001-02-08 17:21:55 +0000
committerAlain Magloire <alainm@rcsm.ee.mcgill.ca>2001-02-08 17:21:55 +0000
commit9409743bdac8ac0478f0746adccab2ddc0513eb0 (patch)
treedf7be26e507199f5b37649ad4734d8984c997b16 /src/Makefile.am
parent5991f478a5a6f2f8d48be945857c53d39279212c (diff)
downloadgrep-9409743bdac8ac0478f0746adccab2ddc0513eb0.tar.gz
Range fixex.
Handle range expressions correctly even when they match strings with two or more characters. * src/dfa.h (CRANGE): New enum value. Comment fix. * src/dfa.c: Include <locale.h> if HAVE_SETLOCALE. Include "hard-locale.h". (prtok): Print CRANGE. (hard_LC_COLLATE): New static var. (lex): Return CRANGE when parsing a character range in a hard locale. Don't use strcoll; it's no longer needed and wasn't correct anyway. Use unsigned rather than token to hold unsigned chars. (addtok): Comment fix. (atom): Treat a CRANGE as if it were (.\1), approximately. (dfaparse): Initialize hard_LC_COLLATE. * src/Makefile.am (base_sources): Add hard-locale.c, hard-locale.h. * src/hard-locale.c, src/hard-locale.h: New files, taken from textutils.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 22270e4b..ca1deb3d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,6 +15,7 @@ base_sources = grep.c grep.h \
savedir.c savedir.h \
xstrtol.c xstrtol.h xstrtoumax.c \
getopt.c getopt1.c getopt.h \
+ hard-locale.c hard-locale.h \
isdir.c \
search.c getpagesize.h system.h
egrep_SOURCES = $(base_sources) egrepmat.c