summaryrefslogtreecommitdiff
path: root/grep.spec
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-04-08 18:39:24 +0200
committerJim Meyering <meyering@redhat.com>2010-04-08 19:29:42 +0200
commit699bcc4bd8166abb6ee26a37d9e1189817741277 (patch)
treeb57f4c9bc3bf24c6b565f78966dc20ff98a4c36a /grep.spec
parente4f69c178ee9e68ecdbd743de669ec8c1388e40f (diff)
downloadgrep-699bcc4bd8166abb6ee26a37d9e1189817741277.tar.gz
convert all TABs to equivalent spaces in indentation
Using this file, cat > leading-blank.exempt <<\EOF (?:^|\/)ChangeLog[^/]*$ (?:^|\/)(?:GNU)?[Mm]akefile[^/]*$ \.(?:am|mk)$ EOF run this command to convert all non-conforming leading white space to be all spaces: git ls-files \ | pcregrep -vf leading-blank.exempt \ | xargs pcregrep -l '^ *\t' \ | xargs perl -MText::Tabs -ni -le \ '$m=/^( *\t[ \t]*)(.*)/; print $m ? expand($1) . $2 : $_'
Diffstat (limited to 'grep.spec')
-rw-r--r--grep.spec2
1 files changed, 1 insertions, 1 deletions
diff --git a/grep.spec b/grep.spec
index 452a1283..4a910e33 100644
--- a/grep.spec
+++ b/grep.spec
@@ -53,7 +53,7 @@ rm -rf ${RPM_BUILD_ROOT}
%preun
if [ $1 = 0 ]; then
- [ -e %{_infodir}/grep.info.* ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.*
+ [ -e %{_infodir}/grep.info.* ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.*
fi
%files -f %{name}.lang