summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-11-28 22:50:34 +0100
committerJim Meyering <meyering@redhat.com>2011-11-28 22:51:14 +0100
commitbbd6d2ec9eb72193b7720dfb568cec751df13509 (patch)
tree99db3edd795e2e29a1828ef85d977b76011590cf /configure.ac
parenta1482fbe39b58e26b8a05d9c5ed22969fbcf2f47 (diff)
downloadgrep-bbd6d2ec9eb72193b7720dfb568cec751df13509.tar.gz
build: accommodate -Werror=suggest-attribute=pure
Now that we're using the latest manywarnings module from gnulib, accommodate gcc's -Werror=suggest-attribute=pure option by marking suggested functions with gnulib-defined _GL_ATTRIBUTE_PURE. * src/kwset.c (hasevery): Mark function with pure attribute. (bmexec): Likewise. * src/dfa.c (nsubtoks, istrstr, find_pred, dfamusts): Likewise. * configure.ac: Disable (for lib/) options that seem not to be worth the trouble: -Wunsuffixed-float-constants and -Wformat-nonliteral.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0478d520..6c0f29d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,6 +164,8 @@ if test "$gl_gcc_warnings" = yes; then
#nw="$nw -Wmissing-prototypes"
nw="$nw -Wold-style-definition"
nw="$nw -Wcast-align"
+ nw="$nw -Wunsuffixed-float-constants"
+ gl_WARN_ADD([-Wno-format-nonliteral])
gl_MANYWARN_COMPLEMENT([GNULIB_WARN_CFLAGS], [$WARN_CFLAGS], [$nw])
AC_SUBST([GNULIB_WARN_CFLAGS])
fi