summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaolo Bonzini <bonzini@gnu.org>2010-09-08 11:39:56 +0200
committerPaolo Bonzini <bonzini@gnu.org>2010-09-14 08:26:56 +0200
commit97744571e8104bebaf7026f584d2a983f997daec (patch)
tree6c96b511a19e1dfb363b8cd205fea5bf1b9be7e1 /configure.ac
parent2c817e28252c67f50e6b798e4bfe18f9d41020ab (diff)
downloadgrep-97744571e8104bebaf7026f584d2a983f997daec.tar.gz
tests: add equiv-classes
* configure.ac (USE_INCLUDED_REGEX): Add Automake conditional. * tests/equiv-classes: New test. * tests/Makefile.am (TESTS): Add it. (XFAIL_TESTS) [USE_INCLUDED_REGEX]: Mark it as expected failure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 01ae0f25..481ce868 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,6 +151,7 @@ dnl Some installers want to be informed if we do not use our regex.
dnl For example, if the host platform uses dynamic linking and the installer
dnl knows that the grep may be invoked on other hosts with buggy libraries,
dnl then the installer should configure --with-included-regex.
+AM_CONDITIONAL([USE_INCLUDED_REGEX], [test "$ac_use_included_regex" = yes])
if test "$ac_use_included_regex" = no; then
AC_MSG_WARN([Included lib/regex.c not used])
fi