summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-09-01 09:08:31 -0700
committerEric Blake <eblake@redhat.com>2012-09-01 09:08:31 -0700
commitad2b8b437a09942a5f98077593a3ffd2c144adb8 (patch)
treee33340e338bbcbbe86deba71f0fb5c6bf367e904 /configure.ac
parent58202fb7619b28cd06ce32913f8650052d5b0c5d (diff)
downloadgrep-ad2b8b437a09942a5f98077593a3ffd2c144adb8.tar.gz
build: work with new glibc when not optimizing
Starting with glibc 2.15, the system headers refuse to compile unconditional use of FORTIFY_SOURCE if optimization is disabled but -Werror is in effect. * configure.ac (FORTIFY_SOURCE): Make conditional.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dc1e5821..a6168c7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,8 +152,13 @@ if test "$gl_gcc_warnings" = yes; then
AC_SUBST([WARN_CFLAGS])
AC_DEFINE([lint], [1], [Define to 1 if the compiler is checking for lint.])
- AC_DEFINE([_FORTIFY_SOURCE], [2],
- [enable compile-time and run-time bounds-checking, and some warnings])
+ AH_VERBATIM([FORTIFY_SOURCE],
+ [/* Enable compile-time and run-time bounds-checking, and some warnings,
+ without upsetting glibc 2.15+. */
+ #if defined __OPTIMIZE__ && __OPTIMIZE__
+ # define _FORTIFY_SOURCE 2
+ #endif
+ ])
AC_DEFINE([GNULIB_PORTCHECK], [1], [enable some gnulib portability checks])
# We use a slightly smaller set of warning options for lib/.