summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-11-29 14:40:47 +0100
committerJim Meyering <meyering@redhat.com>2009-11-30 16:55:04 +0100
commit5a73745b8ada1b9c3c5caea38be911732e04d155 (patch)
tree110cd2f3c09b75d73e12ba1817f8e79712cac81c /configure.ac
parent87c5c2045a87ebf36e948d707d88f160159d0a96 (diff)
downloadgrep-5a73745b8ada1b9c3c5caea38be911732e04d155.tar.gz
build: require automake-1.11, enable silent-rules, parallel tests, xz
* configure.ac (AM_INIT_AUTOMAKE): Create xz-compressed tarballs, not bzip2-compressed ones. Enable automake's silent-rules, parallel tests, and test PASS/FAIL coloring options. Use AC_CONFIG_HEADERS, not AM_CONFIG_HEADER. Quote the argument.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1ec9befa..14b0e9f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,8 +29,10 @@ AC_DEFINE(GREP, 1, [We are building grep])
AC_PREREQ(2.59)
dnl Automake stuff.
-AM_INIT_AUTOMAKE(dist-bzip2)
-AM_CONFIG_HEADER(config.h:config.hin)
+AM_INIT_AUTOMAKE([1.11 dist-xz color-tests parallel-tests])
+AM_SILENT_RULES([yes]) # make --enable-silent-rules the default.
+
+AC_CONFIG_HEADERS([config.h:config.hin])
dnl Check for arguments
AC_ARG_ENABLE(perl-regexp,