summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-01-06 12:06:14 +0100
committerJim Meyering <meyering@redhat.com>2010-02-03 21:52:30 +0100
commit26ad4e6d148f4d56ebb80417711c8a67082d43d7 (patch)
tree8fb79f6a0701eb72526acc7bc6e77ca2cd8e374f /configure.ac
parent222bdcb32ecd45e6be7850515ef3fde0b682c88f (diff)
downloadgrep-26ad4e6d148f4d56ebb80417711c8a67082d43d7.tar.gz
build: avoid warnings in gnulib-supplied regex files
Now that we enable more warnings in lib/, we choose to avoid some via patches applied by bootstrap, using files in the gl/ hierarchy. Other, less-important warnings are avoided simply by turning off the -Wold-style-definition option and using a slightly relaxed set of warnings $(GNULIB_WARN_CFLAGS) in lib/. * gl/lib/regcomp.c.diff: Avoid warnings. * gl/lib/regex_internal.c.diff: Likewise. * gl/lib/regex_internal.h.diff: Likewise. * gl/lib/regexec.c.diff: Likewise. * configure.ac (GNULIB_PORTCHECK): Disable only -Wold-style-definition. * lib/Makefile.am (AM_CFLAGS): Use $(GNULIB_WARN_CFLAGS) rather than the slightly more strict $(WARN_CFLAGS).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1521f7e8..5949f0ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,9 +129,9 @@ if test "$gl_gcc_warnings" = yes; then
# We use a slightly smaller set of warning options for lib/.
# Remove the following and save the result in GNULIB_WARN_CFLAGS.
nw=
- nw="$nw -Wuninitialized"
- nw="$nw -Wunused-macros"
- nw="$nw -Wmissing-prototypes"
+ #nw="$nw -Wuninitialized"
+ #nw="$nw -Wunused-macros"
+ #nw="$nw -Wmissing-prototypes"
nw="$nw -Wold-style-definition"
gl_MANYWARN_COMPLEMENT([GNULIB_WARN_CFLAGS], [$WARN_CFLAGS], [$nw])
AC_SUBST([GNULIB_WARN_CFLAGS])