summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlain Magloire <alainm@rcsm.ee.mcgill.ca>2001-02-08 05:56:49 +0000
committerAlain Magloire <alainm@rcsm.ee.mcgill.ca>2001-02-08 05:56:49 +0000
commit5d6c5528ceaf61a916d667af1a54562c9caa7789 (patch)
tree6906a2870408eb7a4b62f70b01a70c034e430f97 /Makefile.am
parentf850847ef85d69bbebb7bac5490ebccbec7ee8e2 (diff)
downloadgrep-5d6c5528ceaf61a916d667af1a54562c9caa7789.tar.gz
Patch provided by Paul Eggert.
* Makefile.am (ACINCLUDE_INPUTS): Add decl.m4, inttypes_h.m4, uintmax_t.m4, ulonglong.m4, xstrtoumax.m4. * m4/Makefile.am (EXTRA_DIST): Likewise. * src/Makefile.am (base_sources): Add xstrtol.c, xstrtol.h, xstrtoumax.c. (EXTRA_DIST): Add strtol.c. * configure.in (jm_AC_TYPE_UINTMAX_T, jm_AC_PREREQ_XSTRTOUMAX, HAVE_DECL_STRTOUL, HAVE_DECL_STRTOULL): Add. (AC_REPLACE_FUNCS): Add strtoul. * src/grep.c: Include xstrtol.h. (ck_atio): Use xstrtoumax and do proper overflow checking. (max_count, outleft): Now off_t, not int. (main): Likewise. Use xstrtoumax to convert max_count from string. * acconfig.h (HAVE_DECL_STRTOUL, HAVE_DECL_STRTOULL): New #undefs. (HAVE_STPCPY, ENABLE_NLS, HAVE_CATGETS, HAVE_GETTEXT, HAVE_LC_MESSAGES): Remove. * m4/decl.m4, m4/inttypes_h.m4, m4/uintmax_t.m4, m4/ulonglong.m4, m4/xstrtoumax.m4, src/strtol.c, src/strtoul.c, src/strtoull.c, src/strtoumax.c, src/xstrtol.c, src/xstrtol.h, src/xstrtoumax.c: New files, taken unchanged from textutils, fileutils, sh-utils and/or tar.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 76a8a408..64ac4439 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,11 +10,12 @@ EXTRA_DIST = TODO README PATCHES.AC PATCHES.AM
# The following hack works around this bug by creating acinclude.m4 manually.
ACLOCAL_AMFLAGS =
M4DIR = $(srcdir)/m4
-ACINCLUDE_INPUTS = $(M4DIR)/djgpp.m4 $(M4DIR)/dosfile.m4 \
+ACINCLUDE_INPUTS = $(M4DIR)/decl.m4 $(M4DIR)/djgpp.m4 $(M4DIR)/dosfile.m4 \
$(M4DIR)/envsep.m4 $(M4DIR)/gettext.m4 $(M4DIR)/glibc.m4 \
$(M4DIR)/header.m4 $(M4DIR)/init.m4 $(M4DIR)/install.m4 \
- $(M4DIR)/isc-posix.m4 $(M4DIR)/largefile.m4 $(M4DIR)/lcmessage.m4 \
- $(M4DIR)/missing.m4 $(M4DIR)/progtest.m4 $(M4DIR)/regex.m4 \
- $(M4DIR)/sanity.m4
+ $(M4DIR)/inttypes_h.m4 $(M4DIR)/isc-posix.m4 $(M4DIR)/largefile.m4 \
+ $(M4DIR)/lcmessage.m4 $(M4DIR)/missing.m4 $(M4DIR)/progtest.m4 \
+ $(M4DIR)/regex.m4 $(M4DIR)/sanity.m4 $(M4DIR)/uintmax_t.m4 \
+ $(M4DIR)/ulonglong.m4 $(M4DIR)/xstrtoumax.m4
$(srcdir)/acinclude.m4 : $(ACINCLUDE_INPUTS)
cat $(ACINCLUDE_INPUTS) >$(srcdir)/acinclude.m4