summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-03-17 16:14:47 +0100
committerJim Meyering <meyering@redhat.com>2010-03-17 16:14:47 +0100
commit915944fdb2282b380a36f64b5bf58c729b58d90d (patch)
treeec2a80dc71f022e9d78668e3a9049bada77630fe /Makefile.am
parent455f247d1156e877727d2ab1b8d35a5694b01350 (diff)
downloadgrep-915944fdb2282b380a36f64b5bf58c729b58d90d.tar.gz
maint: remove obsolete "cvs-clean" make target
* Makefile.am (cvs-clean): Remove obsolete target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 0 insertions, 30 deletions
diff --git a/Makefile.am b/Makefile.am
index 33a2025f..3ac91d62 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,36 +23,6 @@ SUBDIRS = po lib doc src tests vms gnulib-tests
EXTRA_DIST = build-aux/config.rpath TODO README README-alpha \
Makefile.boot README-boot
-
-# make cvs-clean blatantly stolen from KDE CVS ;)
-cvs-clean:
- @if test ! -d CVS; then \
- echo "You don't have a toplevel CVS directory."; \
- echo "You most certainly didn't use cvs to get these sources."; \
- echo "But this function depends on cvs's information."; \
- exit 1 ;\
- fi;\
- pwd=`pwd` ;\
- dirs=`find . -type d | grep -v CVS | sed -e "s#^./##"` ;\
- for i in $$dirs; do \
- if test ! -d "$$pwd/$$i/CVS"; then \
- echo "D $$i" ;\
- rm -rf "$$pwd/$$i"; \
- continue; \
- fi ;\
- cd $$pwd/$$i ;\
- for f in * .*; do \
- if test ! -d "$$f"; then \
- if grep "^/$$f/" CVS/Entries > /dev/null; then \
- a="b"; \
- else \
- echo "F $$i/$$f"; \
- rm -f "$$pwd/$$i/$$f"; \
- fi; \
- fi ; \
- done; \
- done
-
# Arrange so that .tarball-version appears only in the distribution
# tarball, and never in a checked-out repository.
dist-hook: gen-ChangeLog