summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBernhard Rosenkraenzer <bero@arklinux.org>2001-09-25 13:18:48 +0000
committerBernhard Rosenkraenzer <bero@arklinux.org>2001-09-25 13:18:48 +0000
commit525baae6fb9d5e3538977c538c7a79e9b6b3f6ab (patch)
tree41310ef1b592c33c74dd583f919875b110fe63ab /Makefile.am
parentcfa09c91f9454515e551c8e758b633c1b8f582d3 (diff)
downloadgrep-525baae6fb9d5e3538977c538c7a79e9b6b3f6ab.tar.gz
More autoconf 2.5x/automake 1.5 changes
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ac23373a..8675fe28 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,3 +20,31 @@ ACINCLUDE_INPUTS = $(M4DIR)/decl.m4 $(M4DIR)/djgpp.m4 $(M4DIR)/dosfile.m4 \
$(M4DIR)/uintmax_t.m4 $(M4DIR)/ulonglong.m4 $(M4DIR)/xstrtoumax.m4
$(srcdir)/acinclude.m4 : $(ACINCLUDE_INPUTS)
cat $(ACINCLUDE_INPUTS) >$(srcdir)/acinclude.m4
+
+cvs-clean:
+ @if test ! -d CVS; then \
+ echo "You don't have a toplevel CVS directory."; \
+ echo "You most certainly didn't use cvs to get these sources."; \
+ echo "But this function depends on cvs's information."; \
+ exit 1 ;\
+ fi;\
+ pwd=`pwd` ;\
+ dirs=`find . -type d | grep -v CVS | sed -e "s#^./##"` ;\
+ for i in $$dirs; do \
+ if test ! -d "$$pwd/$$i/CVS"; then \
+ echo "D $$i" ;\
+ rm -rf "$$pwd/$$i"; \
+ continue; \
+ fi ;\
+ cd $$pwd/$$i ;\
+ for f in * .*; do \
+ if test ! -d "$$f"; then \
+ if grep "^/$$f/" CVS/Entries > /dev/null; then \
+ a="b"; \
+ else \
+ echo "F $$i/$$f"; \
+ rm -f "$$pwd/$$i/$$f"; \
+ fi; \
+ fi ; \
+ done; \
+ done